Unable to upload MIDI file

Hi, new user here. The first thing I tried to do with Faders was to upload a MIDI file, but I couldn’t get it to work. What I did was to select My Assets, Asset Type: MIDI, Upload Asset, Browse, and when I selected the file, the progress bar appeared, showing:

bnchord.mid 0.01MB 0%

I then pressed the Upload button, but nothing happened. The JavaScript console showed the error message “DOMException: Unable to decode audio data”.

The MIDI file I tried to upload is here:
https://gson.org/midi/bnchord.mid

Welcome, gson!

Thanks very much for the feedback. You’re right, it appears it’s currently not possible to upload a MIDI file in the My Assets view. We’ll look into this asap.

However, I was able to drag your file into a session onto an existing MIDI track or in empty space. This way, the MIDI file will appear in your assets as well, so you can access it from other sessions too. I hope this helps for what you wanted to do!

Please send us any issues when you encounter them, this is incredibly useful.